<!doctype html>
<html class="no-js" lang="en">
    <head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <meta name="viewport" content="width=device-width,initial-scale=1.0,maximum-scale=1" />

    <title>Frontend development. Jak sprawić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza? | Interaktywnie.com</title>

    <meta name="description" content="W jaki sposób sprawdzić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza? Zdaje się, że odpowiedź na to pytanie jest jasna: należy wdrożyć architekturę CSS-a. Warto uświadomić sobie, że o architekturze należy pomyśleć PRZED napisaniem jakiejkolwiek..." />


    <meta name="keywords" content="css, web development, marketing internetowy, social media, SEO, SEM" />
    
<meta name="robots" content="index,all,follow" />
    
    <link rel="canonical" href="https://interaktywnie.com/biznes/newsy/biznes/frontend-development-jak-sprawic-by-praca-z-css-em-w-duzych-komercyjnych-projektach-byla-przyjemniejsza-262606" />


<meta property="og:title" content="Frontend development. Jak sprawić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza?" />
<meta property="og:url" content="https://interaktywnie.com/biznes/newsy/biznes/frontend-development-jak-sprawic-by-praca-z-css-em-w-duzych-komercyjnych-projektach-byla-przyjemniejsza-262606" />
<meta property="og:site_name" content="interaktywnie.com" />
<meta property="og:description" content="W jaki sposób sprawdzić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza? Zdaje się, że odpowiedź na to pytanie jest jasna: należy wdrożyć architekturę CSS-a. Warto uświadomić sobie, że o architekturze należy pomyśleć PRZED napisaniem jakiejkolwiek linijki kodu CSS-a (a najlepiej jakiegokolwiek kodu [sic!]). W dużych komercyjnych projektach, które cierpią z powodu źle wdrożonego CSS-a, jedynym ratunkiem bywa gruntowny (aczkolwiek wprowadzany ostrożnie) refactoring kodu." />
<meta property="og:image" content="https://interaktywnie.com/public/upload/img/272x200/07/30/73066_arnold-francisca-f77bh3inupe-unsplash.jpg" />
<meta property="og:type" content="article" />

<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "Article",
    "headline": "Frontend development. Jak sprawić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza?",
    "description": "W jaki sposób sprawdzić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza? Zdaje się, że odpowiedź na to pytanie jest jasna: należy wdrożyć architekturę CSS-a. Warto uświadomić sobie, że o architekturze należy pomyśleć PRZED napisaniem jakiejkolwiek linijki kodu CSS-a (a najlepiej jakiegokolwiek kodu [sic!]). W dużych komercyjnych projektach, które cierpią z powodu źle wdrożonego CSS-a, jedynym ratunkiem bywa gruntowny (aczkolwiek wprowadzany ostrożnie) refactoring kodu.",
    "image": {
        "@type": "ImageObject",
        "url": "https://interaktywnie.com/public/upload/img/272x200/07/30/73066_arnold-francisca-f77bh3inupe-unsplash.jpg"
    },
    "publisher": {
        "@type": "Organization",
        "name": "Interaktywnie.com",
        "logo": {
            "@type": "ImageObject",
            "url": "https://interaktywnie.com/public/logo/logo_interaktywnie.jpg"
        }
    }
}
</script>      
    
<link rel="image_src" href="https://interaktywnie.com/public/upload/img/272x200/07/30/73066_arnold-francisca-f77bh3inupe-unsplash.jpg" title="Frontend development. Jak sprawić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza?" />
<meta property="fb:app_id" content="296761753748145" />
            
<link rel="alternate" type="application/rss+xml" title="Interaktywnie.com - hot web spaghetti" href="http://feeds.feedburner.com/interaktywnie" />
    
    <!-- TradeDoubler site verification 2499156 -->
    <meta name="verify-v1" content="P5B/J6TA8pBYI+NJZAxfoRdQDE6tsPyKuPGzTiKM73Q=" />
        
    <link rel="shortcut icon" href="/public/files/fav/favicon.ico">
    <link rel="icon" type="image/png" sizes="114x114" href="/public/files/fav/favicon-114x114.png">
    <link rel="apple-touch-icon" sizes="57x57"href="/public/files/fav/favicon-57x57.png">
    <link rel="apple-touch-icon" sizes="72x72" href="/public/files/fav/favicon-72x72.png">
    <link rel="apple-touch-icon" sizes="114x114" href="/public/files/fav/favicon-114x114.png">
    
    <!--[if IE]>
    <script src="/public/l2019/js/html5shiv.js"></script>
<![endif]-->    
<script type="text/javascript" src="/public/l2019/js/jquery.js"></script>

<link rel="stylesheet" type="text/css" href="/public/l2019/css/bundle_fonts.css" />
<link rel="stylesheet" type="text/css" href="/public/l2019/css/bundle.css?v=14" />

    
    <script>
    var BASE_URL = 'https://interaktywnie.com';
    var MODULE_NAME = 'news';
    var CONTROLLER_NAME = 'news';
    var STRUCTURE_ID = '';
    var OBJ_ID = '0';
    var lock = false;
    var uploadObject = null;
</script>

    
<script>
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-884883-1']);
    _gaq.push(['_setAllowAnchor', true]);
    _gaq.push(['_setDomainName', 'interaktywnie.com']);
    _gaq.push(['_trackPageview']);
    (function() { 
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
    })();
</script>


        <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
        <script>
          var googletag = googletag || {};
          googletag.cmd = googletag.cmd || [];
        </script>

        <script>
          googletag.cmd.push(function() {
            googletag.defineSlot('/108163292/Desktop:Billboard', [[750, 200], [728, 90], [970, 90]], 'div-gpt-ad-1508514903128-1').addService(googletag.pubads());
            googletag.defineSlot('/108163292/Desktop:Right:Rectangle1', [300, 250], 'div-gpt-ad-1500492022212-3').addService(googletag.pubads());
            googletag.defineSlot('/108163292/Desktop:Skyscrapper', [[120, 600], [120, 240]], 'div-gpt-ad-1500492022212-5').addService(googletag.pubads());
            googletag.defineSlot('/108163292/Desktop:Article:Rectangle_Intertext', [300, 250], 'div-gpt-ad-1500492022212-0').addService(googletag.pubads());
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
          });
        </script>
            
    
        <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
        <script>
          var googletag = googletag || {};
          googletag.cmd = googletag.cmd || [];
        </script>

        <script>
          var gptAdSlots = [];
          googletag.cmd.push(function() {
            var mapping0 = googletag.sizeMapping().addSize([1300, 200], [[970, 90], [728, 90], [750, 200]]).addSize([800, 200], [[728, 90], [468, 60], [750, 200]]).addSize([500, 200], [[468, 60], [320, 50]]).addSize([320, 200], [[320, 50], [300, 100], [234, 60]]).build();
            var mapping1 = googletag.sizeMapping().addSize([320, 300], [[300, 250]]).build();
            var mapping2 = googletag.sizeMapping().addSize([1505, 200], [[728, 90], [468, 60], [300, 250]]).addSize([1305, 200], [[468, 60], [320, 50], [300, 250]]).addSize([1155, 200], [[320, 50], [300, 250]]).addSize([800, 200], [[728, 90], [468, 60], [320, 50], [300, 250]]).addSize([500, 200], [[468, 60], [320, 50], [300, 250]]).addSize([320, 300], [[320, 50], [300, 250]]).addSize([320, 200], [[320, 50]]).build();
            gptAdSlots[0] = googletag.defineSlot('/108163292/Responsive:Billboard', [[468, 60], [970, 90], [300, 100], [234, 60], [728, 90], [320, 50], [750, 200]], 'div-gpt-ad-1555177860870-0').defineSizeMapping(mapping0).addService(googletag.pubads());
            gptAdSlots[1] = googletag.defineSlot('/108163292/Responsive:Aside:Rectangle', [300, 250], 'div-gpt-ad-1555177771369-0').defineSizeMapping(mapping1).addService(googletag.pubads());
            gptAdSlots[2] = googletag.defineSlot('/108163292/Responsive:Intertext:Banner', [[300, 250], [728, 90], [320, 50], [468, 60]], 'div-gpt-ad-1555177885748-0').defineSizeMapping(mapping2).addService(googletag.pubads());
            
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
          });
        </script>
            
    <!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '650031528869237'); 
fbq('track', 'PageView');
</script>
<noscript>
<img height="1" width="1" src="https://www.facebook.com/tr?id=650031528869237&ev=PageView&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code --></head>
    <body>
        <div id="fb-root"></div>
        <script>
        window.fbAsyncInit = function() {
            FB.init({
              appId      : '296761753748145',
              status     : true, 
              cookie     : true,
              xfbml      : true,
              oauth      : true,
            });
          };
        (function(d){
            var js, id = 'facebook-jssdk'; if (d.getElementById(id)) {return;}
            js = d.createElement('script'); js.id = id; js.async = true;
            js.src = "//connect.facebook.net/pl_PL/all.js";
            d.getElementsByTagName('head')[0].appendChild(js);
          }(document));
        </script>
        
        <!-- start navigation -->
        <nav class="navbar no-margin-bottom bootsnav alt-font bg-white sidebar-nav sidebar-nav-style-1">
    <div class="col-md-12 col-sm-12 col-xs-12 sidenav-header">     	
        <div class="logo-holder">                
            <a href="https://interaktywnie.com/" class="display-inline-block logo" title="Interaktywnie.com">
                <img alt="Interaktywnie.com" src="/public/themes/frontend/gfx/logos/interaktywnie3.gif" />
            </a>                
        </div>
        <button class="navbar-toggle mobile-toggle" type="button" id="mobileToggleSidenav">
            <span></span>
            <span></span>
            <span></span>
        </button>
    </div>
    
    
<div class="col-md-12 col-sm-12 col-xs-12 no-padding-lr">
    <div id="navbar-menu" class="collapse navbar-collapse no-padding">
        <ul class="nav navbar-nav navbar-left-sidebar font-weight-500">
            
                            <li class="dropdown active">
                    <a href="https://interaktywnie.com/biznes" title="Wiadomości">
                        <span class="text-deep-pink">
                            Wiadomości                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/biznes/artykuly/raporty-interaktywnie-com" title="Raporty">
                        <span>
                            Raporty                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/personalia" title="Personalia">
                        <span>
                            Personalia                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/badania-i-megapanel" title="Badania internetu">
                        <span>
                            Badania internetu                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/kreacja" title="Dobre kampanie">
                        <span>
                            Dobre kampanie                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/praca" title="Praca">
                        <span>
                            Praca                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/wizytowki-firm/1" title="Polecane agencje">
                        <span class="text-deep-pink">
                            Polecane agencje                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                        <ul class="dropdown-menu second-level left-menu-inner" style="width: 430px;">               
                                                                                                                        <li class="dropdown">
                                    <a title="Agencja Interaktywna" href="https://interaktywnie.com/wizytowki-firm/1/agencja-interaktywna" title="Agencja Interaktywna" >
                                        Agencja Interaktywna <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje Reklamowe" href="https://interaktywnie.com/wizytowki-firm/1/agencje-reklamowe" title="Agencje Reklamowe" >
                                        Agencje Reklamowe <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje e-mail marketing" href="https://interaktywnie.com/wizytowki-firm/1/e-mail-marketing" title="Agencje e-mail marketing" >
                                        Agencje e-mail marketing <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje E-commerce" href="https://interaktywnie.com/wizytowki-firm/1/e-commerce" title="Agencje E-commerce" >
                                        Agencje E-commerce <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje Mobile marketing" href="https://interaktywnie.com/wizytowki-firm/1/mobile-marketing" title="Agencje Mobile marketing" >
                                        Agencje Mobile marketing <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencja Public Relations" href="https://interaktywnie.com/wizytowki-firm/1/agencja-public-relations" title="Agencja Public Relations" >
                                        Agencja Public Relations <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje Eventowe" href="https://interaktywnie.com/wizytowki-firm/1/agencje-eventowe" title="Agencje Eventowe" >
                                        Agencje Eventowe <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje Marketing szeptany" href="https://interaktywnie.com/wizytowki-firm/1/marketing-szeptany" title="Agencje Marketing szeptany" >
                                        Agencje Marketing szeptany <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencja Marketingu Zintegrowanego" href="https://interaktywnie.com/wizytowki-firm/1/agencja-marketingu-zintegrowanego" title="Agencja Marketingu Zintegrowanego" >
                                        Agencja Marketingu Zintegrowanego <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje Social Media" href="https://interaktywnie.com/wizytowki-firm/1/social-media" title="Agencje Social Media" >
                                        Agencje Social Media <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje Software House" href="https://interaktywnie.com/wizytowki-firm/1/software-house" title="Agencje Software House" >
                                        Agencje Software House <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Badania/rozwój" href="https://interaktywnie.com/wizytowki-firm/1/badania-rozwoj" title="Badania/rozwój" >
                                        Badania/rozwój <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Bezpieczeństwo informacji" href="https://interaktywnie.com/wizytowki-firm/1/bezpieczenstwo-informacji" title="Bezpieczeństwo informacji" >
                                        Bezpieczeństwo informacji <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Agencje SEO/SEM" href="https://interaktywnie.com/wizytowki-firm/1/seo-sem" title="Agencje SEO/SEM" >
                                        Agencje SEO/SEM <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Butik kreatywny" href="https://interaktywnie.com/wizytowki-firm/1/butik-kreatywny" title="Butik kreatywny" >
                                        Butik kreatywny <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Content Marketing" href="https://interaktywnie.com/wizytowki-firm/1/content-marketing" title="Content Marketing" >
                                        Content Marketing <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Dom Mediowy" href="https://interaktywnie.com/wizytowki-firm/1/dom-mediowy" title="Dom Mediowy" >
                                        Dom Mediowy <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Domeny i hosting" href="https://interaktywnie.com/wizytowki-firm/1/domeny-i-hosting" title="Domeny i hosting" >
                                        Domeny i hosting <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Media" href="https://interaktywnie.com/wizytowki-firm/1/media" title="Media" >
                                        Media <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Edukacja" href="https://interaktywnie.com/wizytowki-firm/1/edukacja" title="Edukacja" >
                                        Edukacja <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Doradztwo i consulting internetowy" href="https://interaktywnie.com/wizytowki-firm/1/doradztwo-i-consulting" title="Doradztwo i consulting internetowy" >
                                        Doradztwo i consulting internetowy <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Projektowanie użyteczności" href="https://interaktywnie.com/wizytowki-firm/1/projektowanie-uzytecznosci" title="Projektowanie użyteczności" >
                                        Projektowanie użyteczności <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Sieć reklamowa" href="https://interaktywnie.com/wizytowki-firm/1/siec-reklamowa" title="Sieć reklamowa" >
                                        Sieć reklamowa <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Sprzęt i elektronika" href="https://interaktywnie.com/wizytowki-firm/1/sprzet-i-elektronika" title="Sprzęt i elektronika" >
                                        Sprzęt i elektronika <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                                                                            <li class="dropdown">
                                    <a title="Inne" href="https://interaktywnie.com/wizytowki-firm/1/inne" title="Inne" >
                                        Inne <i class="fas fa-angle-right"></i>
                                    </a>
                                </li>
                                         
                        </ul>
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/forum" title="Forum">
                        <span>
                            Forum                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/logowanie" title="Zaloguj się">
                        <span>
                            Zaloguj się                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/rejestracja" title="Publikuj w serwisie">
                        <span>
                            Publikuj w serwisie                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/reklama" title="Reklama w portalu">
                        <span>
                            Reklama w portalu                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            <li class="dropdown ">
                    <a href="https://interaktywnie.com/redakcja" title="Redakcja">
                        <span>
                            Redakcja                        </span>
                        <i class="fas fa-angle-right pull-right"></i>
                    </a>
                    
                                        
                </li>
                            
            <li>
                <div class="side-left-menu-close close-side"></div>
            </li>
        </ul>
    </div>
</div>


    
    <div class="col-md-12 position-absolute top-auto bottom-0 left-0 width-100 padding-20px-bottom xs-padding-15px-bottom">
        <div class="footer-holder">
            <form action="https://interaktywnie.com/tag/1" method="get" class="navbar-form no-padding search-box" role="search">
                <div class="input-group add-on xs-margin-10px-bottom">
                    <input type="hidden" name="params" value="all">
                    <input class="form-control" placeholder="Szukaj w serwisie..." name="word" id="word" type="text">
                    <div class="input-group-btn">
                        <button class="btn btn-default" type="submit"><i class="glyphicon glyphicon-search"></i></button>
                    </div>
                </div>
            </form>

            <div class="social-icon-style-8 display-inline-block vertical-align-middle">
                <ul class="small-icon no-margin-bottom">
                    <li><span class="text-medium-gray text-extra-small line-height-none">Jesteśmy też tutaj:</span></li>
                    <li><a class="facebook" href="https://www.facebook.com/interaktywnie/" target="_blank"><i class="fab fa-facebook-f" aria-hidden="true"></i></a></li>
                    <li><a class="twitter" href="https://twitter.com/interaktywnie24" target="_blank"><i class="fab fa-twitter"></i></a></li>
                    <li><a class="linkedin" href="https://www.linkedin.com/company/interaktywnie.com" target="_blank"><i class="fab fa-linkedin"></i></a></li>
                </ul>
            </div>
            
            <div class="icon-social-medium padding-15px-bottom">                
                <div id="fb_like">
                    <div class="fb-like" data-href="http://www.facebook.com/interaktywnie" data-send="false" data-layout="button_count" data-width="450" data-show-faces="false"></div>
                </div>                
            </div>
            <div class="text-medium-gray text-extra-small border-top border-color-extra-light-gray padding-twelve-top xs-padding-15px-top">&copy; 2022 Interaktywnie.com<br />All rights reserved</div>
        </div>
    </div>
</nav>
        <!-- end navigation -->
        <div class="sidebar-wrapper mobile-height">
            

<section class="wow fadeIn padding-20px-tb border-bottom border-color-extra-light-gray">
    <div class="container">
        <div class="row">
            <div class="col-md-12 display-table">
                <div class="display-table-cell vertical-align-middle text-left">
                    <div class="breadcrumb alt-font text-small no-margin-bottom">
                        <ul>
                            <li><a href="https://interaktywnie.com/" class="text-medium-gray" title="Strona główna">Interaktywnie.com</a></li>
                            ﻿                                                        
                                                                                                                                                                                    <li>
                                            <a class="text-medium-gray" href="https://interaktywnie.com/biznes" title="Wiadomości">
                                                Wiadomości                                            </a>
                                        </li>
                                                                                                                                                                                    <li>
                                            <a class="text-medium-gray" href="https://interaktywnie.com/biznes/newsy" title="Newsy">
                                                Newsy                                            </a>
                                        </li>
                                                                                                                                                                                    <li>
                                            <a class="text-medium-gray" href="https://interaktywnie.com/biznes/newsy/biznes" title="Biznes">
                                                Biznes                                            </a>
                                        </li>
                                                                                                                                                                                    <li class="text-medium-gray">
                                            Frontend development. Jak sprawić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza?                                        </li>
                                                                    
                            	                          
                        </ul>
                    </div>
                </div>
            </div>
        </div>
    </div>
</section>


<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https://interaktywnie.com/",
                "name": "Interaktywnie.com"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https://interaktywnie.com/biznes",
                "name": "Wiadomości"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https://interaktywnie.com/biznes/newsy",
                "name": "Newsy"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "https://interaktywnie.com/biznes/newsy/biznes",
                "name": "Biznes"
            }
        }
    ]
}
</script>    
            <div class="margin-15px-tb">
    
        <!-- /108163292/Responsive:Billboard -->
        <div id="div-gpt-ad-1555177860870-0" style="margin:auto;clear:both;text-align:center;min-height:50px;">
        <script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1555177860870-0'); });
        </script>
        </div>  
        </div>    


<section class="wow fadeIn bg-light-gray padding-35px-tb page-title-small top-space">
    <div class="container">
        <div class="row equalize xs-equalize-auto">
            <div class="col-lg-8 col-md-6 col-sm-6 col-xs-12 display-table">
                <div class="display-table-cell vertical-align-middle text-left xs-text-center">
                    <h1 class="alt-font text-extra-dark-gray font-weight-600 no-margin-bottom text-uppercase">
                        Frontend development. Jak sprawić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza?                    </h1>
                </div>
            </div>
            <div class="col-lg-4 col-md-6 col-sm-6 col-xs-12 display-table text-right xs-text-left xs-margin-10px-top">
                <div class="display-table-cell vertical-align-middle breadcrumb text-small alt-font">
                    <ul class="xs-text-center text-uppercase">
                        <li>
                            <span class="text-dark-gray">
                                6.10.2022                            </span>
                        </li>
                        
                                                    
                                                            <li>
                                    <span class="text-dark-gray">
                                        Tomasz Plewka                                    </span>                                
                                </li>
                                                        

                            <li class="text-dark-gray">
                                <a href="/biznes/newsy/biznes/1" title="Newsy: Biznes">Biznes</a>                            </li>
                            
                                                                            
                    </ul>
                </div>
            </div>
        </div>
    </div>
</section>

<section class="padding-30px-top">
    <div class="container">
        <div class="row">
            <main class="col-md-9 col-sm-12 col-xs-12 right-sidebar sm-margin-60px-bottom xs-margin-40px-bottom no-padding-left sm-no-padding-right">
                
                                
                   
                
                <div class="col-md-12 col-sm-12 col-xs-12 blog-details-text last-paragraph-no-margin icom-article">                   
        
            <figure class="main">
            <img src="https://interaktywnie.com/public/upload/img/272x200/07/30/73066_arnold-francisca-f77bh3inupe-unsplash.jpg" alt="fot. Arnold Francisca on Unsplash" title="fot. Arnold Francisca on Unsplash" />
                            <figcaption>fot. Arnold Francisca on Unsplash</figcaption>
                    </figure>
    
    
    <p><strong>W jaki spos&oacute;b sprawdzić, by praca z CSS-em w dużych, komercyjnych projektach była przyjemniejsza?&nbsp;Zdaje się, że odpowiedź na to pytanie jest jasna: należy wdrożyć architekturę CSS-a. Warto uświadomić sobie, że o architekturze należy pomyśleć PRZED napisaniem jakiejkolwiek linijki kodu CSS-a (a najlepiej jakiegokolwiek kodu [sic!]). W dużych komercyjnych projektach, kt&oacute;re cierpią z powodu źle wdrożonego CSS-a, jedynym ratunkiem bywa gruntowny (aczkolwiek wprowadzany ostrożnie) refactoring kodu.</strong></p>
<p style="text-align: center;"><strong><a href="/biznes/newsy/biznes/frontend-development-jakie-wady-ma-css-jakie-nawyki-utrudniaja-prace-z-nim-262567">Przeczytaj r&oacute;wnież: <br />Jakie wady ma CSS i jakie nawyki utrudniają pracę z nim?</a></strong></p>
<p>W og&oacute;lnym ujęciu, architekturą CSS-a nazywamy zestaw zasad i dobrych praktyk, kt&oacute;re mają pom&oacute;c zespołowi developerskiemu tworzyć <strong>łatwy w utrzymaniu, reużywalny, przewidywalny oraz skalowalny kod CSS-a</strong>. Wdrożenie danej architektury obejmuje odpowiednie planowanie w celu nadania pożądanej struktury Twoim arkuszom CSS-a. W dalszej części artykułu przedstawię architekturę promowaną przez Harry&rsquo;ego Robertsa (CSS Wizardry) i opartą o metodologię ITCSS.</p>
<h2>Wprowadzenie do ITCSS oraz wymagania wstępne</h2>
<p style="text-align:center;">
        <!-- /108163292/Responsive:Intertext:Banner -->
        <div id="div-gpt-ad-1555177885748-0" style="margin:auto;clear:both;text-align:center;min-height:50px;">
        <script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1555177885748-0'); });
        </script>
        </div>  
        </p><p>ITCSS (ang. <strong>Inverted-Triangle CSS</strong>) to metodologia wprowadzająca ustrukturyzowany podział projektu CSS na warstwy, kt&oacute;ra po zwizualizowaniu wygląda jak odwr&oacute;cony tr&oacute;jkąt r&oacute;wnoboczny. Nie brzmi zbyt kusząco, prawda? Niemniej Harry Roberts twierdzi, że właśnie to hierarchiczne podejście stanowi model, kt&oacute;ry pomaga w nadaniu odpowiedniej struktury i zaprowadza porządek w CSS-ie w spos&oacute;b bardzo wydajny.</p>
<p>Wspomnianą metodologię zaprojektowano z myślą o komercyjnych projektach, kt&oacute;re bardzo często podczas cyklu życia są skalowane i rozbudowywane. Warto podkreślić, że ITCSS nie jest ani frameworkiem, ani biblioteką CSS-a, a właśnie metodologią lub (jak o tym m&oacute;wi Harry Roberts) sposobem myślenia o tym, jak tworzyć projekty CSS. ITCSS jest niezwykle elastyczny, kompatybilny z innymi metodologiami lub konwencjami nazewnictwa klas (np. SMACSS, BEM), a także może być bez problemu integrowany z preprocessorami CSS-a.</p>
<p style="text-align:center;">
        <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
        <ins class="adsbygoogle"
        style="display:block"
        data-ad-client="ca-pub-6041649676350995"
        data-ad-slot="7317282016"
        data-ad-format="auto"
        data-full-width-responsive="true"></ins>
        <script>
        (adsbygoogle = window.adsbygoogle || []).push({});
        </script>
        </p><p class="no-margin">&nbsp;</p>
<p>Harry Roberts podkreśla, że wydajne wykorzystanie architektury ITCSS wiąże się z następującymi praktykami:</p>
<ul>
<li>odrzucenie używania selektor&oacute;w identyfikatora (ang. ID selectors) w celu &bdquo;spłaszczenia&rdquo; specyficzności w projekcie;</li>
<li>budowanie warstwy UI w oparciu o reużywalne komponenty;</li>
<li>używanie klasowych selektor&oacute;w i brak obiekcji co do umieszczenia dużej ilości klas w warstwie &bdquo;contentowej&rdquo; (HTML&rsquo;u).</li>
</ul>
<h2>Zasady i struktura ITCSS</h2>
<p>ITCSS jest architekturą, kt&oacute;ra dokładnie określa, jak powinien wyglądać projekt CSS. Działa w oparciu o 3 gł&oacute;wne metryki (rys. 3.):</p>
<ul>
<li>zasięg (ang. reach);</li>
<li>szczeg&oacute;łowość (ang. explicitness) oraz</li>
<li>specyficzność (ang. specificity).</li>
</ul>
<p class="no-margin">&nbsp;</p>
<p><img class="captionImage" src="/public/upload/img/620/07/30/73065_zrzut-ekranu-2022-10-5-o-22.34.01.png" alt="73065_zrzut-ekranu-2022-10-5-o-22.34.01.png" /></p>
<p><em>Rys. 3. Poglądowy wykres architektury ITCSS obrazujący 3 metryki. Źr&oacute;dło: other.media.</em></p>
<h2>Zasięg (ang. reach - far-reaching to localised)</h2>
<p>Ta metryka polega na przejściu od selektor&oacute;w o dużym zasięgu na początku projektu do używania selektor&oacute;w, kt&oacute;re wpływają na coraz mniej element&oacute;w DOM-u. Z praktycznego punktu widzenia, można zacząć od napisania og&oacute;lnych reguł resetujących odstępy (za pomocą selektora *), by stopniowo przejść do selektor&oacute;w typu element&oacute;w, a następnie selektor&oacute;w klasowych i tak dalej. Powoduje to zmniejszanie zasięgu selektor&oacute;w, co odpowiada charakterystycznego kształtowi tr&oacute;jkąta w ITCSS.</p>
<h2>Szczeg&oacute;łowość (ang. explicitness - generic to exlicit)</h2>
<p>W tym przypadku chodzi o to, że projekt CSS powinien zaczynać się od tworzenia reguł og&oacute;lnych i zmierzać do stopniowego przejścia do pisania kodu, kt&oacute;ry zmienia pojedyncze własności danego elementu w spos&oacute;b bezpośredni. Przykładem może tu być przejście od og&oacute;lnego resetu, poprzez ostylowanie element&oacute;w typograficznych (h1-h6) aż do tworzenia klas modyfikujących pojedynczą własność (np. `.text-center`).</p>
<h2>Specyficzność (ang. specificity - low specificity to high specificity)</h2>
<p>Niezwykle istotną cechą architektury ITCSS jest poskromienie specyficzności CSS-a. Kluczem do sukcesu jest tworzenie reguł CSS-a ze stopniowo rosnącą specyficznością, rozpoczynając od niskich wartości. W rezultacie unikamy tzw. Specificy Wars, kt&oacute;re potrafią dać się we znaki w dużych, komercyjnych projektach. Warto zaznaczyć, że użytecznym narzędziem, za pomocą kt&oacute;rego możemy zwizualizować oraz ocenić stan specyficzności naszego projektu CSS jest wykres specyficzności (rys. 4.).</p>
<p class="no-margin">&nbsp;</p>
<p><img class="captionImage" src="/public/upload/img/620/07/30/73063_zrzut-ekranu-2022-10-5-o-22.34.11.png" alt="73063_zrzut-ekranu-2022-10-5-o-22.34.11.png" /></p>
<p><em>Rys. 4. Wyidealizowany wykres specyficzności od pozycji reguły CSS&rsquo;a w arkuszu w projekcie opartym o architekturę ITCSS wraz z podziałem na warstwy. Źr&oacute;dło: speakerdeck.com.</em></p>
<h2>Warstwy w ITCSS</h2>
<p>Wdrożenie architektury ITCSS wiąże się z podziałem arkuszy CSS na konceptualne warstwy. Każda kolejna sekwencja jest logicznym następstwem warstwy ją poprzedzającej. Przejście to wiąże się ze zwiększeniem specyficzności, zmniejszeniem zasięgu selektor&oacute;w oraz tworzeniem coraz bardziej szczeg&oacute;łowych reguł CSS-a. Ta tendencja sprawia, że niższe warstwy są coraz &bdquo;węższe&rdquo;, a wynikowy model architektury ITCSS ma kształt odwr&oacute;conego tr&oacute;jkąta. Zachowanie tego schematu sprawia, że kod, kt&oacute;ry piszemy jest łatwiejszy w p&oacute;źniejszym skalowaniu, ponieważ każda kolejna warstwa bazuje na poprzedniej. Wyższe sekwencje nie są nadpisywane, lecz uzupełniane o nowe/brakujące reguły. W efekcie otrzymujemy uporządkowaną bazę kodową, kt&oacute;ra jest przewidywalna i sprzyja utrzymaniu. Warto podkreślić, że jest to r&oacute;wnież korzystne dla zespołu programist&oacute;w, ponieważ każdy nowy developer dołączający do projektu opartego o ITCSS może szybko i bez większego problemu zorientować się, o co w nim tak naprawdę chodzi.&nbsp;</p>
<p>ITCSS składa się z 7 domyślnych warstw (rys. 5):</p>
<ul>
<li>warstwa opcji (ang. settings) &ndash; tutaj umieszczamy globalne zmienne, kt&oacute;re są dostępne z dowolnego miejsca w projekcie. Zmienne odpowiadające danym komponentom powinny być definiowane w odpowiadających im arkuszach CSS albo plikach Sass. Warstwa opcji obejmuje np.: deklaracje czcionek, kolor&oacute;w czy ikon;<br /><br /></li>
<li>warstwa narzędzi (ang. tools) &ndash; zawiera wszystkie globalnie używane funkcje oraz mixin&rsquo;y. Gdy dana funkcja lub mixin dotyczy pojedynczego komponentu, powinien być umieszczony w odpowiednim pliku Sass;  Warto podkreślić, że użycie obu ww. warstw jest zalecane w przypadku, gdy w projekcie używany jest preprocessor (np. Sass). <br /><br /></li>
<li>warstwa og&oacute;lna (ang. generic) &ndash; powinna zawierać og&oacute;lne reguły i jako pierwsza produkuje kod CSS. Przykładowo normalizacje CSS-a, reset odstęp&oacute;w przeglądarki etc.;<br /><br /></li>
<li>warstwa element&oacute;w/bazowa (ang. elements/base) &ndash; tutaj definiujemy reguły dla bezklasowych selektor&oacute;w typu element&oacute;w (np. h1-h6);<br /><br /></li>
<li>warstwa obiekt&oacute;w (ang. objects) &ndash; tu po raz pierwszy pojawiają się selektory klasowe. Pojęcie obiektu znamy choćby z metodologii OOCSS. W ujęciu ITCSS warstwa ta charakteryzuje się wyższą specyficznością (ze względu na selektory klasowe) oraz mniejszą zasięgiem selektor&oacute;w. Obejmuje gł&oacute;wnie wzory projektowe (ang. design patterns) oraz tzw. obiekty, czyli elementy r&oacute;żnego typu od strukturalnych kontener&oacute;w po słynny z metodologii OOCSS obiekt media (ang. media object);<br /><br /></li>
<li>warstwa komponent&oacute;w (ang. components) &ndash; zawiera większość stworzonego kodu. W tym miejscu powstają reguły dla reużywalnych komponent&oacute;w UI, kt&oacute;re docelowo powinny wykorzystywać klasowe selektory;<br /><br /></li>
<li>warstwa klas pomocniczych (ang. utilities lub trumps) &ndash; tu umieszczamy wszystkie klasy pomocnicze oraz tzw. hacki CSS-a. Nierzadko reguły CSS tworzone w tej warstwie zawierają flagę `!important`. Sprawia to, że selektory mają bardzo wysoką specyficzność, co jest celem samym w sobie, ponieważ z założenia nadpisują wszystkie inne reguły występujące w warstwach powyżej.</li>
</ul>
<p><img class="captionImage" src="/public/upload/img/620/07/30/73064_zrzut-ekranu-2022-10-5-o-22.34.18.png" alt="73064_zrzut-ekranu-2022-10-5-o-22.34.18.png" /></p>
<p><em>Rys. 5. Domyślne warstwy w architekturze ITCSS. Źr&oacute;dło: other.media.</em></p>
<h2>Konwencja nazewnictwa klas w ITCSS</h2>
<p>Niezwykle istotną częścią tworzenia klas w CSS-ie stanowi nadawanie im logicznych nazw. W tym przypadku naturalne wydaje się sięgnięcie po dodatkowe narzędzie, kt&oacute;re ten proces znacząco ułatwi.&nbsp;</p>
<p>Konwencja nazewnictwa klas (ang. naming convention) może stanowić pewnego rodzaju uzupełnienie architektury CSS. Harry Roberts poleca wykorzystanie metodologii BEM (ang. Block-Element-Modifier) do nazywania klas. Połączenie architektury ITCSS i nieco zmodyfikowanej przez siebie metodologii BEM nazwał BEMIT. Warto wspomnieć, że poprawne stosowanie metodologii BEM adresuje wiele złych praktyk wspomnianych na początku artykułu. Po dużą dozę rzetelnych informacji oraz opis problem&oacute;w, kt&oacute;re rozwiązuje BEM odsyłam do artykuł&oacute;w autor&oacute;w tej metodologii (en.bem.info/methodology). W pigułce nazwy klas w metodologii BEM (jak sama nazwa wskazuje) składają się z nazwy:</p>
<ul>
<li>bloku &ndash; stanowiącego niezależny komponent UI, np.: `.menu`;</li>
<li>elementu &ndash; każdy komponent składa się z budujących go element&oacute;w, np.: `.menu__item`, `.menu__icon`;</li>
<li>modyfikatora &ndash; oznaczającego poszczeg&oacute;lne warianty danego komponentu UI, np.: `.menu&mdash;primary`, `.menu&mdash;secondary`.</li>
<li> W BEMIT metodologia BEM została zmodyfikowana poprzez wprowadzenie: </li>
<li>przestrzeni nazw (ang. namespace) &ndash; dodając przedrostki odpowiednie przedrostki do istniejących nazw klas, np.: c dla komponentu czy u &ndash; dla klas pomocniczych;</li>
<li>responsywnych przyrostk&oacute;w (ang. responsive suffixes) &ndash; np.: `.menu__item@md`, gdzie md (ang. medium) wskazuje na `breakpoint` w responsywnych regułach `media queries`.</li>
</ul>
<h2>Dobre praktyki w ITCSS</h2>
<h3>Skalowanie/dostosowanie architektury</h3>
<p>ITCSS jest architekturą, kt&oacute;rą można w dowolny spos&oacute;b rozbudowywać, modyfikować i dostosowywać do własnych potrzeb pod kątem zar&oacute;wno `workflow`, jak i zestawu używanych narzędzi. Jeśli Tw&oacute;j zesp&oacute;ł nie używa preprocessora, możesz śmiało pozbyć się dw&oacute;ch pierwszych warstw: opcji oraz narzędzi. Podobnie w przypadku, gdy czujesz, że w Twoim projekcie przyda się nowa, dodatkowa warstwa, możesz ją bez problemu wprowadzić, np. warstwa szablon&oacute;w (ang. themes). Pamiętaj, że technologia jest dla developer&oacute;w, a nie odwrotnie. W związku z tym, nie wahaj się dostosowywać istniejących narzędzi do naszych potrzeb.</p>
<h3>Dobra organizacja folder&oacute;w i plik&oacute;w</h3>
<p>ITCSS narzuca pewnego rodzaju organizację katalog&oacute;w. Warto przy tym zadbać o ten element, ponieważ, jak dobrze wiemy, porządek w kodzie ułatwia i przyśpiesza pracę. Wynikowy plik `index.css` może wyglądać tak:</p>
<p class="no-margin">&nbsp;</p>
<pre>@import 'settings/*';<br />@import 'tools/*';<br />@import 'generic/*';<br />@import 'elements/*';<br />@import 'vendor/*';<br />@import 'objects/*';<br />@import 'components/*';<br />@import 'utilities/*';</pre>
<p class="no-margin">&nbsp;</p>
<h3>Schemat: jeden komponent &ndash; jeden plik</h3>
<p>Odpowiednia organizacja katalog&oacute;w na niewiele się zda, jeżeli nie zadbamy o porządek w folderach zawierających komponenty. Warto tutaj pamiętać, żeby grupować wszystkie elementy danego komponentu w osobnym folderze oraz dany element w pojedynczym pliku `.scss`, np.</p>
<pre>MyComponent/MyComponent.tsx<br />MyComponent/my-component.scss<br />MyComponent/my-component-element.scss</pre>
<p class="no-margin">&nbsp;</p>
<h2>Podsumowując</h2>
<p>I tak to właśnie wygląda. Na koniec sp&oacute;jrzmy raz jeszcze, co daje nam ITCSS oraz BEM (albo BEMIT). Pozwala na:&nbsp;</p>
<ul>
<li>dobrą organizację katalog&oacute;w, porządek w plikach;</li>
<li>uporządkowane katalogi promują pisanie kodu, kt&oacute;ry jest przewidywalny, reużywalny i łatwy w utrzymaniu;</li>
<li>redukcję duplikowania kodu;&nbsp;</li>
<li>developerzy (zar&oacute;wno ci pracujący nad projektem przez dłuższy czas, jak i nowi dopiero zaczynający pracę) wiedzą, gdzie szukać danej grupy reguł CSS;</li>
<li>koniec z tzw. Specificity Wars, ponieważ mamy do czynienia z kodem, kt&oacute;rego specyficzność rośnie stopniowo i w spos&oacute;b przewidywalny&nbsp;</li>
<li>łatwiejsze skalowanie projekt&oacute;w komercyjnych.</li>
</ul>
<p>Tomasz Plewka<br />Frontend Developer<br />SYZYGY Warsaw</p>
<p><strong>Źr&oacute;dła:</strong></p>
<ol>
<li>https://cheesecakelabs.com/blog/css-architecture-first-steps/</li>
<li>https://philipwalton.com/articles/css-architecture/</li>
<li>https://www.xfive.co/blog/itcss-scalable-maintainable-css-architecture/</li>
<li>https://csswizardry.com/2015/08/bemit-taking-the-bem-naming-convention-a-step-further/</li>
<li>https://www.creativebloq.com/web-design/manage-large-css-projects-itcss-101517528</li>
</ol></div>

                <div class="col-md-12 col-sm-12 col-xs-12 padding-40px-top">
    <div class="col-md-6 col-sm-12 col-xs-12 sm-text-center">
        <div class="tag-cloud margin-20px-bottom">
            <a href="https://interaktywnie.com/tag/1/css" title="css">css</a>, <a href="https://interaktywnie.com/tag/1/web+development" title="web development">web development</a>        </div>
    </div>
    <div class="col-md-6 col-sm-12 col-xs-12 text-right sm-text-center">
        <div class="social-icon-style-6">
            <ul class="socialbar extra-small-icon">
                <li><a class="facebook" href="#" data-target="https://www.facebook.com/share.php?u="><i class="fab fa-facebook-f"></i></a></li>
                <li><a class="twitter" href="#" data-target="http://twitter.com/share?url="><i class="fab fa-twitter"></i></a></li>            
                <li><a class="linkedin" href="#" data-target="http://www.linkedin.com/shareArticle?mini=true&url="><i class="fab fa-linkedin-in"></i></a></li>
            </ul>
        </div>
    </div>
</div>    

<script>
$('ul.socialbar a').each(function() {
   $(this).click(function() {
       window.open($(this).data('target')+document.location.href, '_blank', 'left=0,top=150,width=560,height=500,menubar=0,toolbar=0');
       return false;
   });
});
</script>                
                <div class="col-md-12 col-sm-12 col-xs-12">
                    
                <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
                <ins class="adsbygoogle"
                style="display:block"
                data-ad-format="autorelaxed"
                data-ad-client="ca-pub-6041649676350995"
                data-ad-slot="4903569136"></ins>
                <script>
                (adsbygoogle = window.adsbygoogle || []).push({});
                </script>
                                </div>
                
                                
                
<script src="/public/js/system/frontend/markitup/set.js"></script>

<script src="/public/l2019/_private/comments.js"></script>
<script src="/public/l2019/_private/jquery.autogrow.js"></script>

<div class="col-md-12 col-sm-12 col-xs-12 margin-eight-top" id="comments">
    <div class="divider-full bg-medium-light-gray"></div>
</div>

<div class="col-md-12 col-sm-12 col-xs-12 margin-lr-auto text-center margin-80px-tb sm-margin-50px-tb xs-margin-30px-tb">
    <div class="position-relative overflow-hidden width-100">
        <span class="text-small text-outside-line-full alt-font font-weight-600 text-uppercase text-extra-dark-gray">
            Napisz komentarz
        </span>
    </div>
</div>
    
<form class="newsCommentForm" action="https://interaktywnie.com/comments/comments/add/srcmodule/news" method="post">
    <input type="hidden" name="obj_ID" value="262606" />
    <input type="hidden" name="structure_ID" value="141" />
    <input type="hidden" name="commentUri" value="/biznes/newsy/biznes/frontend-development-jak-sprawic-by-praca-z-css-em-w-duzych-komercyjnych-projektach-byla-przyjemniejsza-262606" />
    <input type="hidden" name="ip" value="35.173.238.138" />
            
            <div class="col-md-12 col-sm-12 col-xs-12">
            <p class="text-medium line-height-30 text-medium-gray">
                <a href="https://interaktywnie.com/logowanie" class="text-deep-pink">Zaloguj się</a>, 
                a jeśli nie masz jeszcze konta w Interaktywnie.com - możesz się <a class="text-deep-pink" href="https://interaktywnie.com/rejestracja" title="Zarejestruj się!">zarejestrować</a> albo 
                <a href="#" onclick="return false" class="text-deep-pink fb-login">zalogować przez Facebooka</a>.
            </p>
        </div>
        <div class="col-md-4 col-sm-12 col-xs-12">
            <input name="commentUserName" type="text" placeholder="Autor *" class="medium-input no-margin">
            <div class="wrongFieldTxt medium-input no-padding-lr text-danger" id="commentUserNameError"></div>
        </div>
        
<div class="col-md-8 col-sm-12 col-xs-12">
    <div class="row">        
        <div class="col-md-7 col-sm-7 col-xs-7">
            <input id="captchaText" name="captcha[input]" type="text" placeholder="Kod z obrazka *" class="medium-input no-margin">
            <div class="wrongFieldTxt medium-input no-padding-lr text-danger" id="captchaError"></div>             
        </div>
        <div class="col-md-3 col-sm-3 col-xs-3">
            <span id="captchaWrapper">
                <img src="/public/captcha/f348a9287168deaa88473cd5b5975f56.png" class="captcha"/>
                <input type="hidden" value="f348a9287168deaa88473cd5b5975f56" name="captcha[id]"/>                        
            </span>                        
        </div>
        <div class="col-md-2 col-sm-2 col-xs-2">
            <button href="#" id="captchaReload" type="button" class="btn btn-default"><i class="glyphicon glyphicon-refresh"></i>&nbsp;</button>
        </div>        
    </div>
</div>  
            
        
    <div class="col-md-12 col-sm-12 col-xs-12">
        <textarea id="commentText" name="commentText" placeholder="Napisz swój komentarz..." rows="8" class="medium-textarea no-margin"></textarea>
        <div class="wrongFieldTxt medium-input no-padding-lr text-danger" id="commentTextError"></div>
    </div>
    <div class="col-md-12 col-sm-12 col-xs-12 text-center">
        <button id="addComment" class="btn btn-dark-gray btn-small margin-15px-top" type="buton">Wyślij</button>
    </div>
</form>    

<div class="col-md-12 col-sm-12 col-xs-12" id="commentLoaderBox" style="display:none">
    <div class="alert alert-info alert-dismissable margin-50px-top" >
        <a href="#" class="close" aria-label="close" onclick="$('#commentLoaderBox').hide();return false;">&times;</a>
        <strong>Trwa zapisywanie komentarza...</strong>
    </div>
</div>

<div class="col-md-12 col-sm-12 col-xs-12" id="commentSuccess" style="display:none">
    <div class="alert alert-success alert-dismissable margin-50px-top">
        <a href="#" class="close" aria-label="close" onclick="$('#commentSuccess').hide();return false;">&times;</a>
        <strong>Twój komentarz został dodany!</strong> 
    </div>
</div>    
 
<div class="col-md-12 col-sm-12 col-xs-12 blog-details-comments">    
    <div id="commentList">
            </div>
</div>
 
                
                   
                
                
<div class="col-md-12 col-sm-12 col-xs-12 no-padding">
    <div class="col-md-12 col-sm-12 col-xs-12 margin-lr-auto text-center margin-80px-tb sm-margin-50px-tb xs-margin-30px-tb">
        <div class="position-relative overflow-hidden width-100">
            <span class="text-small text-outside-line-full alt-font font-weight-600 text-uppercase text-extra-dark-gray">
                <a class="text-extra-dark-gray" href="https://interaktywnie.com/wizytowki-firm">wizytówki firm</a>:
                &nbsp;&nbsp;&nbsp;
                <a class="text-deep-pink" href="https://interaktywnie.com/reklama/wyroznij-firme">szukasz klientów dla firmy?</a>
            </span>
        </div>
    </div>
    
    <div class="row equalize md-equalize-auto sm-equalize-auto xs-equalize-auto">
        
        <script type="text/javascript">
<!-- // <![CDATA[
document.write('<scr'+'ipt language="javascript" type="text/javascript" src="//rek.www.wp.pl/dis3rd.html?p=233624,x99,interaktywnie_wizytowki_NuOrder,'+Math.round(Math.random()*1E10)+'"></scr'+'ipt>');
// ]]> -->
</script>        
        <div class="col-md-6 col-sm-6 col-xs-12 last-paragraph-no-margin margin-30px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" >
            <div class="blog-post blog-post-style1 xs-text-center padding-15px-lr">
                <div class="text-center overflow-hidden margin-25px-bottom sm-margin-20px-bottom border-all padding-10px-all sm-no-border">
                    <a href="http://adv.wp.pl/RM/click_lx.ads/Interaktywnie.com/zliczenia.html/L32/1194718909/x99/OasDefault/interaktywnie_wizytowki_NuOrder/interaktywnie_wizytowki_Intellect.html/77643648776c684148584d41436a6170?_RM_REDIR_=http://interaktywnie.com%2Ff%2F210%2Fnuorder">
                        <img class="height-80px width-auto" src="https://interaktywnie.com/public/upload/img/companym/06/27/62748_nuorder_logo_interaktywnie_transparent.png" alt="NuOrder" title="NuOrder">
                    </a>
                </div>
                <div class="post-details">                
                    <a href="" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                        NuOrder                    </a>
                    <p class="margin-15px-top">
                        Pozycjonujemy się jako alternatywa dla agencji sieciowych, oferując konkurencyjną jakość, niższe koszty i...                        <br />
                        <a class="text-deep-pink" href="http://adv.wp.pl/RM/click_lx.ads/Interaktywnie.com/zliczenia.html/L32/1194718909/x99/OasDefault/interaktywnie_wizytowki_NuOrder/interaktywnie_wizytowki_Intellect.html/77643648776c684148584d41436a6170?_RM_REDIR_=http://interaktywnie.com%2Ff%2F210%2Fnuorder" title="profil NuOrder">Zobacz profil w katalogu firm &raquo;</a>
                    </p>
                </div>
            </div>
        </div>
        
        
                
        <div class="col-md-6 col-sm-6 col-xs-12 last-paragraph-no-margin margin-30px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" data-wow-delay="0.2s">
            <div class="blog-post blog-post-style1 xs-text-center padding-15px-lr">
                <div class="text-center overflow-hidden margin-25px-bottom sm-margin-20px-bottom border-all padding-10px-all sm-no-border">
                    <a href="https://interaktywnie.com/f/3204/kordowski-digital-sp-z-o-o">
                        <img class="height-80px width-auto" src="https://interaktywnie.com/public/upload/img/companym/07/29/72917_gads1.png" alt="Kordowski Digital Sp. z o.o." title="Kordowski Digital Sp. z o.o.">
                    </a>
                </div>
                <div class="post-details">                
                    <a href="" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                        Kordowski Digital Sp. z o.o.                    </a>
                    <p class="margin-15px-top">
                        Jesteśmy agencją butikową.Specjalizujemy się w projektach w Europie i obu Amerykach. 

Jesteśmy jedynym...                        <br />
                        <a class="text-deep-pink" href="https://interaktywnie.com/f/3204/kordowski-digital-sp-z-o-o" title="profil Kordowski Digital Sp. z o.o.">Zobacz profil w katalogu firm &raquo;</a>
                    </p>
                </div>
            </div>
        </div>
        
        
                
        <div class="col-md-6 col-sm-6 col-xs-12 last-paragraph-no-margin margin-30px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" data-wow-delay="0.4s">
            <div class="blog-post blog-post-style1 xs-text-center padding-15px-lr">
                <div class="text-center overflow-hidden margin-25px-bottom sm-margin-20px-bottom border-all padding-10px-all sm-no-border">
                    <a href="https://interaktywnie.com/f/2080/tbms-digital-marketing-agency">
                        <img class="height-80px width-auto" src="https://interaktywnie.com/public/upload/img/companym/06/44/64430_logo_tbms.png" alt="TBMS Digital Marketing Agency" title="TBMS Digital Marketing Agency">
                    </a>
                </div>
                <div class="post-details">                
                    <a href="" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                        TBMS Digital Marketing Agency                    </a>
                    <p class="margin-15px-top">
                        Projektujemy i wdrażamy strony internetowe - m.in. sklepy, landing page, firmowe. 
Świadczymy usługi związane z...                        <br />
                        <a class="text-deep-pink" href="https://interaktywnie.com/f/2080/tbms-digital-marketing-agency" title="profil TBMS Digital Marketing Agency">Zobacz profil w katalogu firm &raquo;</a>
                    </p>
                </div>
            </div>
        </div>
        
        
                
        <div class="col-md-6 col-sm-6 col-xs-12 last-paragraph-no-margin margin-30px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" data-wow-delay="0.4s">
            <div class="blog-post blog-post-style1 xs-text-center padding-15px-lr">
                <div class="text-center overflow-hidden margin-25px-bottom sm-margin-20px-bottom border-all padding-10px-all sm-no-border">
                    <a href="https://interaktywnie.com/f/290/mentax-software">
                        <img class="height-80px width-auto" src="https://interaktywnie.com/public/upload/img/companym/07/23/72314_untitled-design-7-e1639912730391-1-.png" alt="MENTAX Software" title="MENTAX Software">
                    </a>
                </div>
                <div class="post-details">                
                    <a href="" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                        MENTAX Software                    </a>
                    <p class="margin-15px-top">
                        Firma MENTAX powstała w 2005 roku. Posiadamy ponad 15-letnie doświadczenie w tworzeniu oprogramowania na...                        <br />
                        <a class="text-deep-pink" href="https://interaktywnie.com/f/290/mentax-software" title="profil MENTAX Software">Zobacz profil w katalogu firm &raquo;</a>
                    </p>
                </div>
            </div>
        </div>
        
        
                
        <div class="col-md-6 col-sm-6 col-xs-12 last-paragraph-no-margin margin-30px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" data-wow-delay="0.4s">
            <div class="blog-post blog-post-style1 xs-text-center padding-15px-lr">
                <div class="text-center overflow-hidden margin-25px-bottom sm-margin-20px-bottom border-all padding-10px-all sm-no-border">
                    <a href="https://interaktywnie.com/f/2990/space-ads">
                        <img class="height-80px width-auto" src="https://interaktywnie.com/public/upload/img/companym/07/15/71531_logo-128x60.png" alt="Space Ads" title="Space Ads">
                    </a>
                </div>
                <div class="post-details">                
                    <a href="" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                        Space Ads                    </a>
                    <p class="margin-15px-top">
                        Dlaczego założyłem Space Ads?

Poznaj historię Rafała Chojnackiego, założyciela agencji.

Słabe agencje i ich...                        <br />
                        <a class="text-deep-pink" href="https://interaktywnie.com/f/2990/space-ads" title="profil Space Ads">Zobacz profil w katalogu firm &raquo;</a>
                    </p>
                </div>
            </div>
        </div>
        
        
                
        <div class="col-md-6 col-sm-6 col-xs-12 last-paragraph-no-margin margin-30px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" data-wow-delay="0.4s">
            <div class="blog-post blog-post-style1 xs-text-center padding-15px-lr">
                <div class="text-center overflow-hidden margin-25px-bottom sm-margin-20px-bottom border-all padding-10px-all sm-no-border">
                    <a href="https://interaktywnie.com/f/2753/ideo-force-sp-z-o-o">
                        <img class="height-80px width-auto" src="https://interaktywnie.com/public/upload/img/companym/06/80/68028_logo.png" alt="Ideo Force Sp. z o.o." title="Ideo Force Sp. z o.o.">
                    </a>
                </div>
                <div class="post-details">                
                    <a href="" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                        Ideo Force Sp. z o.o.                    </a>
                    <p class="margin-15px-top">
                        Pomagamy markom odnosić sukces w Internecie. 

Specjalizujemy się w pozycjonowaniu stron, performance marketingu,...                        <br />
                        <a class="text-deep-pink" href="https://interaktywnie.com/f/2753/ideo-force-sp-z-o-o" title="profil Ideo Force Sp. z o.o.">Zobacz profil w katalogu firm &raquo;</a>
                    </p>
                </div>
            </div>
        </div>
        
        </div>
    
    <div class="col-md-12 col-sm-12 col-xs-12 margin-lr-auto text-center">
        <div class="bg-deep-pink padding-20px-tb text-white text-center">
            <a class="btn btn-transparent-white border-width-1 text-uppercase" href="https://interaktywnie.com/reklama/wyroznij-firme">zamieść tutaj logo swojej firmy</a>
        </div>
    </div>
</div>

                                                 
                
                

<div class="col-md-12 col-sm-12 col-xs-12 no-padding">
    <div class="col-md-12 col-sm-12 col-xs-12 margin-lr-auto text-center margin-80px-tb sm-margin-50px-tb xs-margin-30px-tb">
        <div class="position-relative overflow-hidden width-100">
            <span class="text-small text-outside-line-full alt-font font-weight-600 text-uppercase text-extra-dark-gray">
                Podobne tematy
            </span>
        </div>
    </div>
    
            <div class="col-md-4 col-sm-6 col-xs-12 last-paragraph-no-margin md-margin-50px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" >
        <div class="blog-post blog-post-style1 xs-text-center">
            <div class="blog-post-images overflow-hidden margin-25px-bottom sm-margin-20px-bottom">
                <a href="https://interaktywnie.com/biznes/newsy/biznes/mediamarkt-rusza-z-nowa-kampania-i-otwiera-nowy-etap-budowania-tozsamosci-marki-262605">
                    <img src="https://interaktywnie.com/public/upload/img/272x200/07/30/73061_2.jpg" alt="MediaMarkt rusza z nową kampanią i otwiera nowy etap budowania tożsamości marki" title="MediaMarkt rusza z nową kampanią i otwiera nowy etap budowania tożsamości marki">
                </a>
            </div>
            <div class="post-details">                
                <a href="https://interaktywnie.com/biznes/newsy/biznes/mediamarkt-rusza-z-nowa-kampania-i-otwiera-nowy-etap-budowania-tozsamosci-marki-262605" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                    MediaMarkt rusza z nową kampanią i otwiera nowy etap budowania tożsamości marki                </a>
            </div>
        </div>
    </div>
    
            <div class="col-md-4 col-sm-6 col-xs-12 last-paragraph-no-margin md-margin-50px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" data-wow-delay="0.2s">
        <div class="blog-post blog-post-style1 xs-text-center">
            <div class="blog-post-images overflow-hidden margin-25px-bottom sm-margin-20px-bottom">
                <a href="https://interaktywnie.com/biznes/newsy/e-commerce/empik-uruchamia-platforme-reklamowa-o-nazwie-empik-ads-262603">
                    <img src="https://interaktywnie.com/public/upload/img/272x200/07/30/73060_1.jpg" alt="Empik uruchamia platformę reklamową o nazwie Empik Ads" title="Empik uruchamia platformę reklamową o nazwie Empik Ads">
                </a>
            </div>
            <div class="post-details">                
                <a href="https://interaktywnie.com/biznes/newsy/e-commerce/empik-uruchamia-platforme-reklamowa-o-nazwie-empik-ads-262603" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                    Empik uruchamia platformę reklamową o nazwie Empik Ads                </a>
            </div>
        </div>
    </div>
    
            <div class="col-md-4 col-sm-6 col-xs-12 last-paragraph-no-margin md-margin-50px-bottom sm-margin-50px-bottom xs-margin-30px-bottom wow fadeIn" data-wow-delay="0.4s">
        <div class="blog-post blog-post-style1 xs-text-center">
            <div class="blog-post-images overflow-hidden margin-25px-bottom sm-margin-20px-bottom">
                <a href="https://interaktywnie.com/biznes/newsy/ludzie/artur-sztarbalo-zostal-creative-directorem-w-agencji-kamikaze-262601">
                    <img src="https://interaktywnie.com/public/upload/img/272x200/07/30/73057_2.jpg" alt="Artur Sztarbało został Creative Directorem w agencji Kamikaze" title="Artur Sztarbało został Creative Directorem w agencji Kamikaze">
                </a>
            </div>
            <div class="post-details">                
                <a href="https://interaktywnie.com/biznes/newsy/ludzie/artur-sztarbalo-zostal-creative-directorem-w-agencji-kamikaze-262601" class="post-title text-medium text-extra-dark-gray width-90 display-block sm-width-100">
                    Artur Sztarbało został Creative Directorem w agencji Kamikaze                </a>
            </div>
        </div>
    </div>
    
        
</div>

                
            </main>
            
            <aside class="col-md-3 col-sm-12 col-xs-12 pull-right"> 
                
                <div id="rightContainer">
    <div class="margin-45px-bottom xs-margin-25px-bottom">
        <a href="https://interaktywnie.com/wizytowki-firm">
        <div class="text-extra-dark-gray margin-25px-bottom alt-font text-uppercase font-weight-600 text-small aside-title">
            <span>Wizytówki firm</span>        
        </div>
    </a>
    <div class="instagram-follow-api">
        
                            <ul>
                            <li>
                    <figure>
                                                <a href="https://interaktywnie.com/f/2080/tbms-digital-marketing-agency" title="TBMS Digital Marketing Agency">
                            <img src="https://interaktywnie.com/public/upload/img/companym/06/44/64430_logo_tbms.png" class="insta-image">
                            <span class="insta-counts">TBMS Digital Marketing Agency</span>
                        </a>
                    </figure>
                </li>
                            <li>
                    <figure>
                                                <a href="https://interaktywnie.com/f/290/mentax-software" title="MENTAX Software">
                            <img src="https://interaktywnie.com/public/upload/img/companym/07/23/72314_untitled-design-7-e1639912730391-1-.png" class="insta-image">
                            <span class="insta-counts">MENTAX Software</span>
                        </a>
                    </figure>
                </li>
                            <li>
                    <figure>
                                                <a href="http://adv.wp.pl/RM/click_lx.ads/Interaktywnie.com/zliczenia.html/L32/1194718909/x99/OasDefault/interaktywnie_wizytowki_NuOrder/interaktywnie_wizytowki_Intellect.html/77643648776c684148584d41436a6170?_RM_REDIR_=http://interaktywnie.com%2Ff%2F210%2Fnuorder" title="NuOrder">
                            <img src="https://interaktywnie.com/public/upload/img/companym/06/27/62748_nuorder_logo_interaktywnie_transparent.png" class="insta-image">
                            <span class="insta-counts">NuOrder</span>
                        </a>
                    </figure>
                </li>
                            <li>
                    <figure>
                                                <a href="https://interaktywnie.com/f/2753/ideo-force-sp-z-o-o" title="Ideo Force Sp. z o.o.">
                            <img src="https://interaktywnie.com/public/upload/img/companym/06/80/68028_logo.png" class="insta-image">
                            <span class="insta-counts">Ideo Force Sp. z o.o.</span>
                        </a>
                    </figure>
                </li>
                            <li>
                    <figure>
                                                <a href="https://interaktywnie.com/f/2990/space-ads" title="Space Ads">
                            <img src="https://interaktywnie.com/public/upload/img/companym/07/15/71531_logo-128x60.png" class="insta-image">
                            <span class="insta-counts">Space Ads</span>
                        </a>
                    </figure>
                </li>
                            <li>
                    <figure>
                                                <a href="https://interaktywnie.com/f/3204/kordowski-digital-sp-z-o-o" title="Kordowski Digital Sp. z o.o.">
                            <img src="https://interaktywnie.com/public/upload/img/companym/07/29/72917_gads1.png" class="insta-image">
                            <span class="insta-counts">Kordowski Digital Sp. z o.o.</span>
                        </a>
                    </figure>
                </li>
                        </ul>
                
    </div>
    
    <div class="bg-deep-pink padding-20px-tb text-white text-center margin-45px-bottom xs-margin-25px-bottom">
        <a class="btn btn-transparent-white border-width-1 text-uppercase" href="https://interaktywnie.com/reklama/wyroznij-firme">zamieść tutaj<br />logo swojej firmy</a>
    </div>
    
</div>    <div class="margin-45px-bottom xs-margin-25px-bottom">
        <a href="https://interaktywnie.com/komentarze">
        <div class="text-extra-dark-gray margin-25px-bottom alt-font text-uppercase font-weight-600 text-small aside-title">
            <span>Ostatnie komentarze</span>        
        </div>
    </a>
   
            <ul class="latest-post position-relative">
            
                                            <li>           
                    <div class="no-padding-lr display-table-cell vertical-align-top text-small">
                        <span class="clearfix text-medium-gray text-small">Magda Szwedik</span>
                        <a href="https://interaktywnie.com/biznes/newsy/biznes/youtube-wprowadza-nowe-sposoby-zarabiania-i-sumuje-kwote-wyplaca-tworcom-262596#komentarze" class="text-extra-dark-gray">
                            <span class="display-inline-block margin-5px-bottom">YouTube wprowadza nowe sposoby zarabiania i sumuje kwotę wypłaconą twórcom</span>
                        </a>
                        <span class="clearfix text-small">Żeby zarabiać na youtube trzeba się nieźle napocić i mieć dobry pomysł na</span>
                    </div>
                </li>

                                            <li>           
                    <div class="no-padding-lr display-table-cell vertical-align-top text-small">
                        <span class="clearfix text-medium-gray text-small">Rigatoni</span>
                        <a href="https://interaktywnie.com/biznes/newsy/biznes/wojciech-mann-w-kampanii-olx-podpowiada-jak-zmienic-prace-262577#komentarze" class="text-extra-dark-gray">
                            <span class="display-inline-block margin-5px-bottom">Wojciech Mann w kampanii OLX. Podpowiada, jak zmienić pracę</span>
                        </a>
                        <span class="clearfix text-small">Z całym szacunkiem- dla jakiego odsetka osób ewentualnie poszukujących pracy</span>
                    </div>
                </li>

                                            <li>           
                    <div class="no-padding-lr display-table-cell vertical-align-top text-small">
                        <span class="clearfix text-medium-gray text-small">Wiktoria</span>
                        <a href="https://interaktywnie.com/biznes/newsy/biznes/instagram-aktualizuje-swoja-skrzynke-odbiorcza-dm-262077#komentarze" class="text-extra-dark-gray">
                            <span class="display-inline-block margin-5px-bottom">Instagram aktualizuje swoją skrzynkę odbiorczą DM</span>
                        </a>
                        <span class="clearfix text-small">Chcę założyć Instagrama skrzynkę odbiorczą</span>
                    </div>
                </li>

                        
        </ul>
            
        
        
    
</div>    <div class="margin-45px-bottom xs-margin-25px-bottom">
        <div class="text-extra-dark-gray margin-25px-bottom alt-font text-uppercase font-weight-600 text-small aside-title">
        <span>newsletter</span>        
    </div>
    <div class="display-inline-block width-100">
        <form action="https://interaktywnie.com/rejestracja" method="post">
            <div class="position-relative">
                <input type="hidden" name="dontValidate" value="1">
                <input type="hidden" name="businessNewsletter" value="1">
                <input type="email" name="email" required="" class="bg-transparent text-small no-margin border-color-extra-light-gray medium-input pull-left" placeholder="Podaj swój adres email...">
                <button type="submit" class="bg-transparent text-large btn position-absolute right-0 top-3" title="Zapisz się">
                    <i class="far fa-envelope no-margin-left"></i>
                </button>
            </div>   
            <div class="position-relative">
                <div class="float-right margin-5px-top">
                    <a href="http://freshmail.pl/" rel="noopener" target="_blank">
                        <img src="//interaktywnie.com/public/files/freshmail.gif" width="100" height="22" alt=" "/>
                    </a>
                </div>
             </div>
        </form>
    </div>
</div></div>    
<div id="flyerItem">
    
        <!-- /108163292/Responsive:Aside:Rectangle -->
        <div id="div-gpt-ad-1555177771369-0" style="margin:auto;clear:both;text-align:center;min-height:250px;">
        <script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1555177771369-0'); });
        </script>
        </div>  
        </div>
<script>
    (function() {
        try {            
            $(document).ready(function() {
                var flyerItem = document.getElementById('flyerItem');
                var rightContainer = document.getElementById('rightContainer');                        
                                
                if (!flyerItem || !rightContainer) {
                    return;
                }
                
                var viewportWidth = Math.max(document.documentElement.clientWidth, window.innerWidth || 0);
                var asideParent = document.getElementById('rightContainer').parentNode.parentNode;
                
                $(document).scroll(function() {
                    if (viewportWidth < 991) {
                        return;
                    }
                    
                    var advRect = flyerItem.getBoundingClientRect() || { top: 0, height: 0 }
                    var rightRect = rightContainer.getBoundingClientRect() || { top: 0, height: 0 }
                    var asideParentRect = asideParent.getBoundingClientRect() || { top: 0, height: 0 }
                                                
                    var outside = asideParentRect.top + asideParentRect.height - advRect.height - 60;    
                                                
                    if (outside < 0) {
                        // flyerItem.style.position = 'fixed';
                        // flyerItem.style.top = (outside) + 'px'; 
                        flyerItem.style.position = 'relative';
                        flyerItem.style.top = 0;
                    } else if (rightRect.top + rightRect.height < 0) {
                        flyerItem.style.position = 'fixed';
                        flyerItem.style.top = 0;                    
                    } else {
                        flyerItem.style.position = 'relative';
                        flyerItem.style.top = 0;
                    }
                });
                
                $(window).resize(function() {
                    viewportWidth = Math.max(document.documentElement.clientWidth, window.innerWidth || 0);
                });
            });
        } catch (ex) {}
    })();
</script>     
                
            </aside>
            
        </div>
    </div>
</section>            <!-- start footer --> 
                        <section class="wow fadeIn md-padding-two-lr sm-no-padding-lr no-padding-top padding-50px-bottom">
    <div class="container">
        <div class="row equalize sm-col-2-nth">

            <div class="col-lg-4 col-md-6 col-sm-6 col-xs-12 margin-six-bottom md-margin-six-bottom sm-margin-30px-bottom wow fadeInUp last-paragraph-no-margin">
                <div class="feature-box-5 position-relative">
                    <i class="icon-desktop text-medium-gray icon-medium"></i>
                    <div class="feature-content">
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/o-nas">O nas</a>
                        </div>                        
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/redakcja">Redakcja</a>
                        </div>
                    </div>
                </div>
            </div>

            <div class="col-lg-4 col-md-6 col-sm-6 col-xs-12 margin-six-bottom md-margin-six-bottom sm-margin-30px-bottom wow fadeInUp last-paragraph-no-margin" data-wow-delay="0.2s">
                <div class="feature-box-5 position-relative">
                    <i class="icon-pricetags text-medium-gray icon-medium"></i>
                    <div class="feature-content">
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/reklama">Reklama</a>
                        </div>                        
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/bloguj-z-nami">Publikuj u nas</a>
                        </div>
                    </div>
                </div>
            </div>

            <div class="col-lg-4 col-md-6 col-sm-6 col-xs-12 margin-six-bottom md-margin-six-bottom sm-margin-30px-bottom wow fadeInUp last-paragraph-no-margin" data-wow-delay="0.4s">
                <div class="feature-box-5 position-relative">
                    <i class="icon-chat text-medium-gray icon-medium"></i>
                    <div class="feature-content">
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/patronat-medialny">Patronat medialny</a>
                        </div>                        
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/kontakt">Kontakt</a>
                        </div>
                    </div>
                </div>
            </div>

            <div class="col-lg-4 col-md-6 col-sm-6 col-xs-12 sm-margin-six-bottom md-margin-six-bottom sm-margin-30px-bottom wow fadeInUp last-paragraph-no-margin" data-wow-delay="0.6s">
                <div class="feature-box-5 position-relative ">
                    <i class="icon-documents text-medium-gray icon-medium"></i>
                    <div class="feature-content">
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/regulamin-serwisu">Regulamin</a>
                        </div>                        
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/polityka-prywatnosci">Polityka prywatności</a>
                        </div>
                    </div>
                </div>
            </div>

            <div class="col-lg-4 col-md-6 col-sm-6 col-xs-12 xs-margin-30px-bottom wow fadeInUp last-paragraph-no-margin" data-wow-delay="0.8s">
                <div class="feature-box-5 position-relative">
                    <i class="icon-mobile text-medium-gray icon-medium"></i>
                    <div class="feature-content">
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/forum">Forum</a>
                        </div>                        
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/archiwum/data">Archiwum</a>
                        </div>
                    </div>
                </div>
            </div>
                        
            <div class="col-lg-4 col-md-6 col-sm-6 col-xs-12 wow fadeInUp last-paragraph-no-margin" data-wow-delay="1s">
                <div class="feature-box-5 position-relative">
                    <i class="icon-tools-2 text-medium-gray icon-medium"></i>
                    <div class="feature-content">
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/nasze-logo">Nasze logo</a>
                        </div>                        
                        <div class="text-extra-dark-gray margin-5px-bottom alt-font font-weight-600">
                            <a href="https://interaktywnie.com/rss">RSS</a>
                        </div>
                    </div>
                </div>
            </div>
                        
        </div>
    </div>
</section>

<footer class="footer-center-logo bg-light-gray padding-30px-tb xs-padding-30px-tb">
    <div class="container">
        <div class="row">
            <div class="col-md-4 col-sm-4 col-xs-12 text-small alt-font display-table xs-margin-20px-bottom">
                <div class="display-table-cell vertical-align-middle">                    
                    <a href="https://interaktywnie.com/">
                        <img src="//interaktywnie.com/public/themes/frontend/gfx/logos/interaktywnie4Grey.gif" alt="Interaktywnie.com">
                        <br />
                        &nbsp;&COPY; by <a href="https://interaktywnie.com/">Interaktywnie.com</a> 2022                    </a>                                        
                </div>                
            </div>                        
            <div class="col-md-8 col-sm-8 col-xs-12 display-table">
                <div class="display-table-cell vertical-align-middle text-small">
                    Używamy plików cookies<br/>
                    Aby lepiej dostosować nasz serwis do tego, co lubisz czytać oraz aby wyświetlić Ci jak najlepiej dopasowaną reklamę, 
                    używamy plików cookies. Współpracujemy przy tym z Google. 
                    <a href="/polityka-prywatnosci" class="text-black">Tutaj znajdziesz więcej informacji na ten temat.</a>
                </div>
            </div>           
        </div>
    </div>
</footer>

            <!-- end footer -->
        </div>
        
        <!-- start scroll to top -->
        <a class="scroll-top-arrow" href="javascript:void(0);"><i class="ti-arrow-up"></i></a>
        <!-- end scroll to top  -->
        
        <script type="text/javascript" src="/public/l2019/js/bundle.js?v3"></script>

        <div class="buy-theme alt-font md-display-none">
    <a href="mailto:reklama@interaktywnie.com" target="_blank">
        <i class="ti-shopping-cart"></i>
        <span>Zamów reklamę w portalu</span>
    </a>
</div>
<div class="all-demo alt-font md-display-none">
    <a href="https://interaktywnie.com/rejestracja">
        <i class="ti-email"></i>
        <span>Zapisz się na newsletter</span>
    </a>
</div>    </body>
</html>